BNY Mellon changes over to ComputerShare

Discussion in 'UPS Discussions' started by GameCockFan, May 15, 2013.

  1. GameCockFan

    GameCockFan Active Member

    Except the migration is a total disaster. I can't login to Computershare. It doesn't recognize my previous id. If you press forgot id it sends an email that says

    "Unfortunately we cannot find any information for your entered email address
    Please confirm your email and try again.

    According to it's not working for most. Good job UPS. If I performed this way I'd already have a warning letter and have my job threatened. To quote one of the articles on the website
    "99.9 Percent Isn't Acceptable".

    Looks like you batting way less than 50% on this one.
  2. over9five

    over9five Moderator Staff Member

    x2. Doesn't work for me either.
  3. ups hero

    ups hero Member

    It takes about 4 maybe 5 times to get logged in, it's frustrating but it eventually works, for me at least.
  4. Catatonic

    Catatonic Nine Lives

    That for customers ... you are not a customer.

    Wait until you get converted to CVS Caremark.
    That company, its processes and results are an absolute joke.
    I figure I have spent over 40 hours getting my Rx straight with them.
    ​People seem nice and try to be helpful ... their fulfillment systems seems to be in beta or maybe alpha, definitely not ready for prime time.
    You can't even track the shipment and delivery of your prescriptions.
    Last edited: May 15, 2013
  5. Jackburton

    Jackburton Gone Fish'n

    McDonald's direct shares use the new service also. We cashed out once with them and it was very simple.
  6. brown metal coffin

    brown metal coffin Active Member

    They must have been tweaking it all day because I got in just fine. Logged in on the original BNY Mellon and they forwarded me to the new computershare site. Gave login and PW and it was all good. They made me create some new security questions but that was it. Bada Bing...
  7. brownmonster

    brownmonster Man of Great Wisdom

    I could never see my account the old way. I was finally able to log in to this new account.
  8. GameCockFan

    GameCockFan Active Member

    Still not working for me. Login at the equity access site. Forwards me to new CompShare site. Use same info and can't login. Email reset says no info found. Guess I'll give it a coule more days and call.
  9. over9five

    over9five Moderator Staff Member

    ​Same here. I fired 'em off a nastygram.
  10. bluehdmc

    bluehdmc Well-Known Member

    I was able to log in last nite. I was previously with BNY and Computershare. The shares I had on BNY other than UPS were moved to my previous Computershare account. When I went to log in thru equity access to Computer share I had to use a new user name because I was using the same name on my previous Computershare account.
    The only thing I don't like is I basically have to have 2 accounts with Computershare, 1 for UPS employee and 1 for my other holdings. Just a bit of a pain if I want to check balances.
  11. over9five

    over9five Moderator Staff Member

    Didn't have time to try this today, but their reply email says:

    · Web Browsers: Computershare’s Website is supported by Internet Explorer (IE) 5.5+, Mozilla Firefox 3.0+, Safari, and Opera 9.2+ browsers. If you do not have one of these browsers, you will need to download one to view Computershare’s website.

    I used Google Chrome when I last tried it, so maybe that's the problem.
  12. over9five

    over9five Moderator Staff Member

    ..........and today I got a new temporary password by USPS.

    Tried to log in..... personal id doesn't work. It said to use the same one you had for Mellon. Whatever, I use the "forgot ID" link. EMails me a 25 character id. I KNOW that wasn't it, but I try it.
    It works, and I use the temp password. It works too. Changed both immediately.

    All's good in da neighborhood.

    PS I did it with Chrome, so apparently Chrome works with the site.
  13. preload1

    preload1 Member

    When you call the toll free number and you want to speak to a live person keep pressing the "0" key and it will put a live person on the phone in less that 15 seconds. I did this drill yesterday and the person I was connected with was very helpful. He stayed on the phone with me for 30 minutes until everything was complete.
  14. UpstateNYUPSer

    UpstateNYUPSer Single digit midget!

    This also works if you ever have to call 1-800-PICKUPS.
  15. balland chain

    balland chain Member

    I have tried this computershare site at least 15 times.. I get to the login page, enter my info, then sometimes I get as far as seeing my holdings.. Then when I click on a drop down to get my tax information, it sends me back to the login page, then it starts to load, then goes idle.. This is madness !! Only UPS , and yeah if we did our job this way, we would be fired immediately !!!! I am not sure if the problems are due to my use of a Mac, as I have been told two years ago that I needed a windows machine to extract my info.. I guess I will borrow a friends computer and give it a shot tomorrow.. Anybody else have a problem like this that uses a Mac ?
  16. ZJ NOMAD

    ZJ NOMAD New Member

    Could it be internet is to slow? If you get to see your holdings that means your in, seems kind of strange to me.

    Well I logged in to BNY Mellon a couple weeks back it took me to Computershare with the same Personal ID, and password that I had with BNY I got into Computershare with no problem, it did make me change my password, but I keeped the same personal ID.

    I think computershare works better than BNY, I linked my bank account to make additional purchases, and it was a doozie, very simple to use.
  17. brownmonster

    brownmonster Man of Great Wisdom

    ​Did mine on a Mac.