Glitchy Diad/cradle

gman042

Been around the block a few times
At random times the diad will seize up and the scan function is disabled. It will not scan and you cannot perform a manual key entry. The only thing to do is reboot. I did that at least a dozen times yesterday. After about 5 time of rebooting, the navigation is disabled.
And then there are days that there will be no issue at all.
We have tried a new diad and a new cradle with the same result.
I am just wondering if this is typical with others experiencing the same or just a random occurrence. Or perhaps all this technology is rebelling and starting to show its true glitchy nature.
 

DriverNerd

Well-Known Member
Any issues I've had with glitchy DIADs have been fixed with a replacement DIAD. I've never had a bad cradle that affected the DIAD in any way besides not displaying the navigation because of a bad connection.
 

Ghost in the Darkness

Well-Known Member
DIAD freezes maybe 3-5 time a year. Reboot works most of the time, pulled battery off then put back on for the rest. If that doesn't work it prbly needs to be sent away for repair.
Cradles are junk, they are not durable at all. The devil lights come on (orange lights at the top) and the screen shuts off. Spend more distracting time trying to get it working than before just scrolling to find stops. Green charging light flickers all day. One cradle fell off the mount. Pins stick and need a lubrication especially on rural routes with dusty roads. I've had 3 cradles fail so far.
 
Top